Lipetsk *nix Association Forum Lipetsk *nix Association Forum
Новости: С 7.09.2011 отправка личных сообщений разрешена только пользователям из группы новичков (4 и более публичных сообщений). Ибо спамеры просто задолбали.
 
*
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Вам не пришло письмо с кодом активации?
19 Ноябрь 2017, 15:12:46


Войти


Страниц: [1]   Вниз
  Печать  
Автор Тема: Критическая уязвимость в bash, которая может привести к удалённому запуску коман  (Прочитано 1917 раз)
0 Пользователей и 1 Гость смотрят эту тему.
NeO
Злобный админчик
Администратор
*****

Карма: 62
Сообщений: 2371

Debian Stretch

ОС:
Linux Linux
Браузер:
Firefox 32.0 Firefox 32.0


WWW Награды
« : 24 Сентябрь 2014, 22:09:22 »

Подробности

Проверить уязвимость можно такой командой:

Код:
env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
Если выводит

Код:
vulnerable
this is a test
То система уязвима.

Добавлено: 25 Сентябрь 2014, 13:41:35
Эпопея продолжается.
После исправления нашли другой способ эксплуатации:

env X='() { (a)=>\' bash -c "echo date"; cat echo

http://www.opennet.ru/opennews/art.shtml?num=40670

Пока апдейтов нет.
« Последнее редактирование: 25 Сентябрь 2014, 13:41:35 от NeO » Записан
Aspid
Юзверь
**

Карма: 0
Сообщений: 31


Debian 7.0 && Windows 7

ОС:
Windows 7 Windows 7
Браузер:
Firefox 31.0 Firefox 31.0


WWW Награды
« Ответ #1 : 29 Сентябрь 2014, 14:25:20 »

root@netvds:~# uname -amrs
Linux netvds 2.6.32-042stab090.5 #1 SMP Sat Jun 21 00:15:09 MSK 2014 x86_64 GNU/Linux


root@netvds:~# env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
vulnerable
this is a test
root@netvds:~#


Грустный(((((((
пичаль-пичаль.. умельцы ещё не нашли костыль для фикса?
« Последнее редактирование: 29 Сентябрь 2014, 14:28:52 от Aspid » Записан
Yazichnik
Небритый одмин
*****

Карма: 8
Сообщений: 709

Mac OS X, Debian

ОС:
Linux Linux
Браузер:
Chrome 37.0.2062.94 Chrome 37.0.2062.94


Награды
« Ответ #2 : 29 Сентябрь 2014, 17:58:35 »

вчера в апдейтах для wheezy была сборка баша
Записан
NeO
Злобный админчик
Администратор
*****

Карма: 62
Сообщений: 2371

Debian Stretch

ОС:
Linux Linux
Браузер:
Firefox 32.0 Firefox 32.0


WWW Награды
« Ответ #3 : 30 Сентябрь 2014, 14:53:03 »

root@netvds:~# uname -amrs
Linux netvds 2.6.32-042stab090.5 #1 SMP Sat Jun 21 00:15:09 MSK 2014 x86_64 GNU/Linux


root@netvds:~# env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
vulnerable
this is a test
root@netvds:~#


Грустный(((((((
пичаль-пичаль.. умельцы ещё не нашли костыль для фикса?
Нифига ты долго думал. Все, что в первом посте, заапдейтили еще 26 числа и эти дырки уже весьма активно используют все, кому не лень.
Уже 4 новых дырки нашли и закрыли, а ты все без обнов (=

https://github.com/hannob/bashcheck - тут скрипт для проверки баша на все найденные уязвимости сразу.
Записан
7c00h
Продвинутый
***

Карма: 1
Сообщений: 169


ОС:
Windows NT 6.3 Windows NT 6.3
Браузер:
Chrome 38.0.2125.104 Chrome 38.0.2125.104


WWW Награды
« Ответ #4 : 21 Октябрь 2014, 04:20:09 »

Код:
,---
| SailfishOS 1.0.8.19 (Tahkalampi) (armv7hl)
'---
[nemo@Jolla ~]$ uname -a
Linux Jolla 3.0.31-cyanogenmod-gf1d51e5 #7 SMP PREEMPT Fri Aug 15 21:14:34 UTC 2014 armv7 GNU/Linux
[nemo@Jolla ~]$ env x='() { :;}; echo vulnerable'  bash -c "echo this is a test"
this is a test
[nemo@Jolla ~]$
Ну  все дожили, придется телефон менять.
Записан

Nokia N810
Страниц: [1]   Вверх
  Печать  
 
Перейти в:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2011, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM